Motorola Moto G3 Forum

Textra Cannot Send Messages

I use Textra to send and receive messages but recently I have only been able to receive messages. I cannot send new messages or replay to incoming messages. Please help me resolve this problem.
 

Related:

#1 casey1958, May 23, 2018
Does it work with a different app? And is Textra set as your default?

Might be useful to know what Android version you are running too.
 
#2 Hadron, May 23, 2018
^^^This. When you receive text, all installed message apps can read the database that it's put into, but only the default app can send/reply.
 
#3 lunatic59, May 23, 2018
The Android version is 6.0.1. I can send and receive emails using Aquamail.

How do I check that Textra is my defaul messaging app?

Thanks you for responding.
 
#4 casey1958, May 23, 2018
settings>apps>menu>configure apps and you should see a list for defaults. Message app should say Textra.
 
#5 lunatic59, May 23, 2018
Phones always use 1 messaging app to send texts.
If you are already using textra then it is the default messaging app
 
#6 Dannydet, May 23, 2018
If it isn't it will probably tell you when you launch it. I don't know android 6 well (skipped it), but on my phone I can check default apps in Settings > Apps.

Aquamail is email, which is completely different from SMS.

I don't suppose you noticed any change before this problem started: system update, app update, installed another app that can send SMS or gave it permissions (making it the default in the process)? Restoring SMS from a backup could do that (the backup app has to be made default to do this), or if you let something like Messenger access SMS it could become default.
 
#7 Hadron, May 23, 2018
One other thought ... are you on an unlimited SMS plan with your carrier or have you reached some sort of limit?
 
#8 lunatic59, May 23, 2018
The Messenging app was the default app until I installed Textra and it has worked flawlessly for many months. I could not check that this was the default app using the settings path given above because the only choices available from the menu are Show System and Reset App Preferences. However, when I try to use Messaging it gives me a warning message stating the Textra is my SMS app.
 
#9 casey1958, May 23, 2018
Just a quick test ... set messaging to default and then try and send a text. If it doesn't go through there may be a problem with your account. Check with your carrier. If it works then the problem is textra.
 
#10 lunatic59, May 23, 2018
I sent an SMS message using Messaging but it failed! My wife has exactly the same phone and uses the Textra messaging app without and problems.in our home using our wi-fi connection and so it is not a problem with our broadband connection or broadband provider (TalkTalk).
 
#11 casey1958, May 23, 2018
SMS messages are not sent through WiFi. They are sent through your voice connection.
 
#12 lunatic59, May 23, 2018
Okay, but we both use the same Moto G3 phone and I have used my at the same time using Textra and have no problems. I have checked the RAM usage and there is plenty of spare capacity and so I don't think that is a RAM issue.
 
#13 casey1958, May 23, 2018
One more test ... put the sim card from your wife's phone in yours and then send a text. If that works, then it's your account. If it doesn't there's something on your phone preventing any text message from being sent. (you could also put your sim in her phone and see if you can text that way.)
 
#14 lunatic59, May 23, 2018
I have fixed the problem! The phone is on a 'pay as you go' account and it had got to £0.11 credit - not enough to send text messages (or make phone calls for that matter). I topped up the account and now all is well. I would have expected EE (my phone provider) to warn me when I run out of credit. Anyway, thanks for your help.
 
#15 casey1958, May 24, 2018
Check your account preferences with EE, as notifications and warning messages might be turned off.
 
#16 mikedt, May 24, 2018
The alert was set at £1.00 and so it should have occurred when credit dropped below this value. Perhaps a glitch by EE.
 
#17 casey1958, May 24, 2018